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Disclaimer: 

The makers of this software cannot be held liable for the final quality 
of indexes produced with it. Responsibility for the final accuracy and 
completeness of any index lies with the indexer. 
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Read this first 

On purchasing WordEmbed you will receive the WordEmbed program file. This 
is in the form of a Word Template called wordEmbedDistrib.dot (or 
WordEmbedDemo.dot), however this is not to be put in the Templates directory, 
opened or double-clicked upon. Doing so will produce a new document based 
on this template, rather than installing the WordEmbed software for you to use 
on any document you open in Word. 

Other files should be downloaded from the WordEmbed webpage: 
https://jalamb.com/wordembed/ 

� WordEmbed.pdf – the user manual (this document) 

� WordEmbed Sky/Cindex/Macrex Tutorial.pdf 

� Gleig.doc – an example Word file used in the tutorials 

The recommended sequence is: 

1. Follow the instructions in the next section and install WordEmbed on 
your system. 

2. Read through the appropriate Tutorial and follow it through yourself, 
using the Gleig.doc file supplied. 

3. Read through the rest of this User Manual to understand WordEmbed 
properly before using it. 
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Installation 

To install WordEmbed on your system, copy the 

WordEmbed program file, wordEmbedDistrib.dot into 

Word's Startup area - 

For some people, those will be all the instructions necessary. Others will need 
more help. The less you know, the more you need to read below. 

 

Copying the file 

Do not double-click on the WordEmbedDistrib.dot or open it in Word (and then 
save it), as this will corrupt the file. If you do this, download it afresh and start 
again. 

 

Restarting Word 

Word is sometimes used in the background by other applications, such as 
Outlook, so often it is still running even though there is no Word window open 
nor Word button showing in the taskbar. It needs to be closed down completely 
and restarted, as it only checks the Startup directory when it starts. If in doubt, 
reboot the machine, which guarantees that Word does restart. 

 

Finding the Word/Startup directory 

Typically, the directory is: 

 

• Word 2000, 2002 (XP), 2003, 2007, and 2010 under Windows 2000 or 
XP 
C:\Documents and Settings\::username::\Application 
Data\Microsoft\Word\Startup 
(::username:: is the user name of the currently logged-in user) 

• Word 2000, 2002 (XP), 2003, 2007, and 2010, 2013 under Windows 
Vista, Windows 7 & 8 
C:\Users\::username::\AppData\Roaming\Microsoft\Word\Startup 
(::username:: is the user name of the currently logged-in user) 

Caution: Do not confuse this directory with the OFFICE Startup directory – 
putting the file there will appear to work, but will then cause security messages 
about “untrusted macros”. 

 

You may need to turn on “show hidden files” 

 

1. Open Folder Options by clicking the Start button Picture of the Start 
button, clicking Control Panel, clicking Appearance and 
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Personalization, and then clicking Folder Options. 

2. Click the View tab. 

3. Under Advanced settings, click Show hidden files, folders, and drives, 
and then click OK. 

Try copying the file to the typical location and restart Word 

If that doesn’t work, it is possible that the location of the Startup directory has 
been changed on your setup. The current location can be found in the Options 
window of Word: 

Word 2003 and earlier:  

• Open the Tools menu and click Options. Under the ‘File Locations’ tab 
you will find the Startup directory. 

 

Word 2007 or later: 

• Click Office Button > Word Options > Advanced (in Word 2007) or 
Click File > Options > Advanced (in Word 2010) 

• Click File Locations to bring up the File Locations dialog. In the File 
Types list, choose Startup. 

• Click the Modify button (even though you won’t be modifying anything.) 
to display the Modify Location dialog box. Select and copy the path name 
for the Startup folder in the Look In drop down list at the top of the 
dialogue 

• Open File explorer (Windows Key + E) [Windows Key is the one 
between Ctrl and Alt], paste the path name for the Startup folder in the 
address bar at the top of the dialogue box and press Enter button to open 
the Startup location. This directory is where the file needs to be placed. 
Drag and drop it in, or cut and paste it into this window. 

 

The Word Startup area has special privileges assigned, so if the file is correctly 
located there, you should not get security warnings. 

For more information on installation go to: 
https://jalamb.com/wordembed/wordembed-installation/ 
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Upon restarting Word you should find that, in Word 2003, the WordEmbed 
toolbar should be visible. 

 

This is unlikely to be exactly where you want the toolbar. You can move it by 
left clicking on the dotted line at its far left and dragging.  

You can turn it off, for now, by right clicking on any toolbar and clicking on the 
Embedding line. You can turn it back on in the same way. 

In Word 2007, click on the Add-Ins tab to find the WordEmbed buttons (the 
bottom row of icons in the picture below) 

 

 

In later versions of Word the Add-Ins tab shows as a drop-down list. 

Toolbar gone missing? If 
it has disappeared from 
the right-click drop-down 
menu, see 
TroubleShooting: Where 
has my Toolbar Gone? 
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Introduction 

Embedding an index in Word 
Embedding directly into Word (without WordEmbed) involves: 

• Insertion of hidden {XE} fields throughout the document. This requires that 
the indexer works in “Show All” mode which clutters the screen with 
paragraph and formatting symbols, making it more difficult to read. 

• Each locator range must have a bookmark created for it for its inclusion in 
the {XE} fields, requiring multiple key strokes and mouse actions. 

• Once the first draft version of the index has been created, modification of a 
heading requires that all the {XE} fields for that heading, and all its 
subheadings, throughout the document must be modified, either individually 
or using global replace (and hoping that you haven't changed the original 
document text). 

• Word always uses word-by-word sorting 

WordEmbed allows the indexer to create their index in their usual indexing 
software and embed the resulting index into the Word document. 

This allows the indexer to: 

• work from an uncluttered view of the original document 

• taking full advantage of their usual indexing software to create and edit the 
index efficiently, in a familiar software environment 

• separate the indexing process from the embedding process, allowing the 
indexer to concentrate on understanding and indexing the text, leaving the 
indexing technicalities until the end 

• use word-by-word or letter-by-letter sorting 

 

Please read through this manual before using this product. Also, it is vital to try 
out the procedure on a small file in order to understand to the process properly 
before committing to using it on a full size index. 
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Overview 

Embedding an index with WordEmbed 
After installing WordEmbed, the procedure for creating an embedded index 
using is: 

1. Once you have identified a paragraph, word, or point in the text you 
wish to refer to, you click on that location in the Word document, press 
a key and receive a ‘temporary locator number’ in the paste buffer. A 
bookmark and comment are temporarily placed at this point in the text, 
so that the program and you can refer back to it if you wish. 

2. You then paste the temporary locator (something like 124.10) into your 
own indexing software and add the index heading. 

3. Repeat from step 1 ad nauseum. 

4. Once the index is complete, you print your index to an RTF file in a 
very specific format and feed it into WordEmbed which will create 
embedded index fields in the Word document, and Word generates the 
index in the Word document. 

5. You then can press a button to clean up the document, removing the 
temporary bookmarks and comments, to give a client-ready document 
which looks exactly as if the Word index was produced by hand. 

The end result is an embedded index, containing only the minimum number of 
bookmarks which Word requires for the indexed text ranges. 
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Getting locators 

Click-Copy-Paste 
To obtain a locator, position the cursor at a point in the Word document, or 
select a piece of text, and press Ctrl-Shift-\ – that is, hold down the leftmost 
Ctrl key, hold down the Shift key above it, and press the \ key. 

(If the view selected is one which is not suitable for the embedding process, the 
program will ask permission to change view. If you say 'No' then locators will 
not be provided and the embedding cannot work, so say ‘Yes’!) 

The locator provided will two numbers separated by a dot, e.g. 1.40 

This will be copied into the clipboard so that you can paste it into your indexing 
software and will usually be displayed in a comment on the screen. However, if 
the location is in the Footnote or Endnotes, however, a comment cannot be 
added, but a pop-up message box confirms that the locator has been created. 
This is not a problem. You can still paste the locator into your indexing 
software, it is just that you cannot see the locator number easily if you need to 
go back to it. 

 

Do remember that a double-click in Word will select the whole word – a triple 
click will select a whole paragraph. This can be a lot easier that clicking and 
dragging. 

A single locator may refer to a single point in the text or a range of text. 
Furthermore, when using the locator in your indexing program, you may use a 
single locator or a pair of locators (from-to, e.g. 1.4 - 2.3). Also, a locator 
(although it only appears in one place in the Word document) may be used many 
times in an index (in multiple headings). 

You can also use  
Alt-Ctrl-G if you prefer 

Here two locators have 
been inserted. The first 
marking a point in the text; 
the second marking a 
selection of text. 

Important! 
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You may have a single locator referring to a point in the text, but, if you want to 
refer to a range of text, it can be done several ways. You may have a single 
locator which refers to a range of text, or one locator defining the start of the 
range, and another defining the end. Both locators themselves could be points or 
ranges.An example may clarify... 
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Using locators 

 

 

In the above there are 3 locators: 1.40 at the top, 1.110 in the middle, and 1.240 
at the end of the 3

rd
 verse. The middle one is a defines a range – the whole 

second verse. 

We can use any of the following locators in the indexing program: 

1.40  A point just before the words “The sun was shining” 

1.110  A range “The moon ... spoil the fun!” 

1.40-1.110 A range “The sun was ... spoil the fun!” 

1.40-1.240 A range “The sun was ... no birds to fly.” 

1.110-1.240 A range “The moon ... no birds to fly.” 

1.240  A point just after the words “no birds to fly.” 

This, including the 
highlighting, is how the 
screen appears in Word 
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Locators 
The locator 1.40 represents a locator on page 1, line 4. If another locator is 
created on the same line, it will be 1.41, then 1.42 and so on. 

This numbering scheme is used for convenience only, so that, when working on 
the index in your indexing software, you can have some idea of where in the 
document these locators refer. The places in the document are actually held by 
temporary bookmarks and so it is not a problem if the paging of the document is 
changed, or the text itself changed, after the locators have been created, as long 
as the bookmarks are not deleted. 

The page number part of the locator is NOT the page number which will appear 
in the index. 

Permanent bookmarks 
Word does require bookmarks to be created to define text ranges referred to in 
the index. These permanent bookmarks are created during the embedding 
process and are prefixed “jalambcomWE” to ensure that they do not conflict 
with any other bookmarks you wish to use or are already present. Only the 
minimum number possible of these permanent bookmarks are created. They are 
used multiple times in the index where possible. 

Temporary bookmarks 
have names beginning 
with “comjalambwe” so 
they won't get mixed up 
with existing bookmarks 
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External index formats 
WordEmbed requires the file used to transfer the index from your indexing 
software to be in a very specifc, Chicago Manual of Style indented layout. This 
layout is not connected in any way with the index layout that will appear in the 
Word document, which is produced and controlled within Word. 

The index provided for embedding must be: 

• an rtf file 

• indented, using two spaces for indenting levels: 

 

So, sub-headings must start with two spaces; sub-sub-headings with four spaces; 
and so on. It does not matter whether they are visually indented on the screen, 
using the ruler line in the text editor, WordEmbed will not see that. It requires 
the spaces. 
 

• no turn-around lines – no wrapping 

• colon (:) used for separating heading levels on the same line 

• comma-space (, ) separating heading from locators 

• comma-space(, ) separating locators from each other 

 

• Cross-references must be prefixed by dot-space-See-space, 

 
Anything may follow this, so “. See also “ and “. See under “ are valid. The 
text here does appear in the final index in Word, so the letters “See” may be 
replaced by another string on the Embed Index screen where the index is in a 
language other than English.  
 

• locator ranges may be joined by hyphen or en-rule (Alt-0150) 

• Headings, parts of headings and locators may be in normal upright, italic or 
bold font. 

• Headings, or parts of headings, may be in coloured fonts. 

• colons in headings, if not separating levels, must be enclosed in curly 
brackets, so: 
    Airplane II{:} The Sequel, 1.190 

• Word only allows 6 levels of heading, so that should not be exceeded. 

• The order of entries is not important – the sorting of the final index is 
controlled by Word. 

• Parts of headings enclosed in curly brackets are hidden from  the sort  
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So: 

Beijing University 
    {as }comprehensive (zonghe) institution 
    establishment of 
    funding 
    Guanghua School of Management 
    history 
    place in hierarchy 
    reliance on foreign experts for teaching ICT 
    {as }source of US doctorates 
    world ranking 

NOTE that Word will sort on a leading space, so the space following the 
preposition should be included in the brackets 

• Parts of headings enclosed in tilde characters (~) are hidden from display. 
 

So: 

~199508~Windows 95 
~199806~Windows 98 
~200002~Windows 2000 
~200009~Windows ME 
~200110~Windows XP 
~200701~Windows Vista 
~200910~Windows 7 
~201210~Windows 8 
~201507~Windows 10 

Displays as: 

Windows 95 
Windows 98 
Windows 2000 
Windows ME 
Windows XP 
Windows Vista 
Windows 7 
Windows 8 
Windows 10 

•  

Example 
Mozart, Wolfgang Amadeus, 2.30, 8.40 
cat keeping, 1.60 
catalogues, 1.60 
Putnam 
  Putnam's Italy, 2.160–2.30 
    Naples, 2.30 
      Mafia, 30.40 
        Sicily, 30.10 
          agents, 30.110 
        zoos, 3.60 
Scandinavians. See Norwegians 
universal institutions, 1.160–2.160. See also Norwegians; institutions 

Tilde is Shift # on my 
keyboard – near the Enter 
key 
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Embedding the index 

• Open the original document in Word. It is, of course, critical that the 
document still retains the temporary bookmarks which were created when 
the locators were obtained. 

• Click the Embed Index button.  

This will bring up this dialogue box: 

 

Multiple Sequence prefix 
Usually left blank, this allows you to include more than one index in a single 
Word document. 

Word handles multiple sequences by adding a \f switch to both the index entries 
and the index statement itself. This flag is followed by a single character which 
is used to match the index statement to its entries. This defaults to 1, but can be 
changed. This is not displayed on the index in any way, it is only used to match 

The index file should not 
be open in Word at this 
time – if it is you will be 
asked to close it. 
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index entries to their sequence. 

For example, you might have an Authors index and a Subjects index. These 
should be created as two separate RTF files. The Authors index could be loaded 
using the default Multiple Sequence Prefix and the Subjects index loaded using 
the prefix “S”. This will result in a mixture of entries fields throughout the 
document, some having { XE \f  “1” } and others having { XE \f “S”}. At the 
end of the document there will be two index fields one { INDEX \f “1”}, which 
will produce the Authors index, and the other { INDEX \f “S”} which will 
produce the Subjects index. The actual characters 1 and S are not shown 
anywhere on the displayed indexes. The indexer must then enter into the Word 
document page breaks before the indexes and titles for them. 

String to define Cross-Refs 
If you do not change it this value will be “See”, indicating that cross-references, 
whether See, See also or See under, all begin with See, triggering the special 
treatment of the text as a cross-reference. 

This can be changed to another string if, for example, you were producing an 
index in a language other than English. Normally this should not be changed. 

CMS indented layout/Macrex MBK 
Always select CMS. (MBK is no longer used) 

Letter-by-Letter Sort 
Word always sorts indexes in word-by-word order. Clicking this box will have 
the same effect as surrounding all the spaces in every heading with curly 
brackets and therefore excluding them from the sort. This achieves letter-by-
letter sorting. 

Last subhead Cross-Refs 
Word will normally position cross-references at the end of the heading line to 
which they refer. A more usual layout for indexes is to have the cross-ref as the 
last subheading under the heading. There is no way within Word’s index 
formatting to do this. 

Checking this box will achieve the correct appearance in the final index, by 
turning the cross-reference into a subheading which looks like a cross-reference. 

Suppress Cross-Refs 
Checking this field will stop cross-refs being included in the embedding. You 
will normally wish to leave this blank to have the cross-refs included. 

When embedding a single index into multiple files (for example, separate files 
for each chapter) it is necessary to suppress the cross-refs in all but one file, so 
that the cross-refs only appear once in the merged index. 

Do not use this option if 
you are using Word 
embedding as a means of 
sending an index to the 
CUP-XML process or 
Quark.  
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OK Button 
Press the OK button and you will be requested to select the file containing the 
index.  

Once you select the file the embedding process will start, the blue progress bar 
will travel from left to right and, when completed, you will be positioned at the 
bottom of the document at the start of your index. During the embedding process 
you should not carry out any cut and paste operations elsewhere (such as in an 
email client) as this may interfere with the embedding process. In fact, Word 
prefers to have as much of the machine as it can get, so now is a good time to go 
and have a walk away from the computer! 

If the index contained locators for which matching bookmarks could not be 
found in the document, a new document is created containing a list of those 
missing locators. 

Once started the Cancel 
button changes to Stop and 
pressing this will interrupt 
the process. The index will 
only be partially inserted. 
It is best not to save this 
version of the document!  
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After Embedding 

Formatting the index in Word 

After embedding you may want to modify the formatting of the index. In order 
to do this you will need to right click within the index and select the Toggle 
Field Codes option or Edit Field. After making your changes you will need to 
right click and select Update Field. Similarly, if you make changes to the 
pagination of the document, use Update Field to have the index locators match 
the new pagination. 
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Removing Temporary Bookmarks 

 

This button will remove all the temporary bookmarks and comments. Once 
removed, you will no longer be able to embed your index into this document, so 
ensure that you save a copy of the document and embed your index before using 
this button. Once the index has been embedded, this button can safely be used 
without affecting the finished embedded index – all the necessary permanent 
bookmarks will be left intact. 

Specifically, this button will remove all bookmarks prefixed with 
“comjalambwe” and all comments by the author “-WE”. 

You will probably wish to 
do this as a courtesy to 
your client, who may find 
hundreds of unnecessary 
bookmarks confusing. 
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Finding a Location 

The Go To Locator button will bring up the window: 

 

You may enter a single locator or a locator pair, separated by a hyphen. If the 
locator denotes a range then that range will be highlighted. If it denotes a point, 
the character after the point will be highlighted. 

This box may be safely moved and repositioned on the screen and may but kept 
on screen while carrying out other functions within Word. 

This may be useful when 
editing your index to 
check to where a locator 
actually points or what a 
range includes. 



WordEmbed 

https://jalamb.com/wordembed/  

19 

 

CUP-XML 

 

 

Unless you are doing work for Cambridge University Press you are unlikely to 
be interested in this button. 

CUP operate a system whereby their indexers are supplied with a book in Word 
format and they must return the index in a separate RTF file with tags for the 
locators (not the headings!) embedded in the Word document. 

The full process is described on the web page http://jalamb.com/cup.html 

The CUP tags must be unique throughout the whole document and so, if CUP 
send the book to you in chapters (as is likely) these should be merged into a 
single document before embedding. 

If you are indexing for CUP, then click the “Turn CUPXML ON” button. The 
button will change to be “Turn CUPXML OFF” and the bulb picture on it will 
light up, to remind you that it is on. 

Select your location in the document, either a point or a range, and, press 
Ctrl Shift \ This will insert the locator (or locator pair for a range) and put the 
locator into the clipboard, which you can paste/enter into your indexing 
software. 

You must enter only a single locator into your software – you must not use a 
two-locator range (as you are able to normally with a fully embedded index). In 
order to denote a range of text you must select it and get a single locator for it. 

Also, unlike a normal Word embedded index, you are allowed to use suffixes in 
your RTF index, to indicate such things as tables. For example 14.10t 

Produce your index in your indexing software, but do not embed it into the 
Word document. 

Do Not press the Remove Temporary Bookmarks button. 

The Word file and your index are now ready to be sent to CUP. 

Note that the CUP locators not truly embedded – they are actually highlighted 
text inserted into the document. 

Care: This is different 
from the normal 
functionality described 
above 
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Techniques 

Multi-file documents 
Word has two mechanisms for handling multi-file documents: Master 
Documents and Referenced Documents. 

A Master Document is a document which contains links to subdocuments. When 
the Master Document is opened the subdocuments are included into the Master 
Document, so that the whole of the resulting document can be seen in the Master 
Document. The formatting of the Master Document is also applied to the 
subdocuments and this can result in pagination changes. 

A Reference Document is one referred to by an RD field, which is not made 
visible in the main document, but its content is made available for producing a 
table of contents, table of authorities or an index. Consequently, any embedded 
index fields, XE fields, in the referenced documents are included when the index 
is generated. 

If the text you wish to index has been supplied as a separate Word file for each 
chapter (perhaps as each chapter is produced by the author!) then it is best to use 
RD fields to bring them together to create a single index. 

Let us assume that we have three files, Chap01, Chap02 and Chap03. 

To ensure that locator references are unique across all the documents, it is 
necessary to ensure that the page numbers are unique across all the documents. 
So, Chapter one may start at page 1, which is default and needs no change, but 
Chapter two should start, say, at page 35. It does not actually matter what the 
page numbers are, as they have no effect on the final index, but it is important 
that a page does not appear in two documents. 

To set the page numbering for Chapter two: 

� open file Chap02.doc 

� position the cursor on the first page 

� Insert > Page Numbers > Format... 

� Start At > 35 > OK > Close 

Be careful to enter Close, rather than OK, otherwise you will add a visible page 
number to the bottom of the page. 

In addition to normal Arabic numerals, you can set the page numbering to be 
roman numerals, for example for prelims, and this will be successfully carried 
through to the final index. 

Chapter 3 may start at page 76, so we follow the same process for Chap03.doc 

Setting the page number in this way, sets it for the whole section, rather than the 
whole document. If the document contains multiple sections, perhaps because 
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there is a mixture of portrait and landscape format pages, then the page number 
may need to be set at the start of each section. It is easiest to check that the page 
number at the end of each document is now as you expect it to be. 

Now index each of the chapter documents, creating a single Sky/Cindex/Macrex 
index using the Ctrl-| locators from all three documents, and edit the final 
Sky/Cindex/Macrex index as you wish. 

Embed the Sky/Cindex/Macrex index into each of the chapter documents. The 
first document should be embedded normally, but for the rest it is necessary to 
check the “Suppress Cross-Refs” box, otherwise the cross-references will be 
entered into each file and so appear multiple times in the final index. 

The embedding process will result in lots of rejections, but that is OK – in the 
Chap01.doc, all the index entries for Chap02 and Chap03 will reject, but the 
Chap01 entries will be embedded successfully; in the Chap02.doc, all the index 
entries for Chap01 and Chap03 will reject, but the Chap02 entries will be 
embedded successfully; and so on. Each chapter file will contain an index at the 
end, formed from only the entries for that chapter, but that too is OK. 

To create the combined index, create a new document, and enter RD fields: 

� Create a new blank document in the same directory as the chapter files 

� Set Show/Hide to Show (click on the ¶ button) 

� Insert> Field> RD 

� Filename or URL: Chap01.doc 

� Check the box: Filename is relative to current doc 

This will show as { RD  Chap01.doc \f } 

Repeat inserting RD fields for each chapter document, or copy and paste the 
field and then edit it, resulting in: 

{ RD  Chap01.doc \f } 
{ RD  Chap02.doc \f } 
{ RD  Chap03.doc \f } 
 

Be careful that the documents are included in the correct order, as this will 
determine the order of locators after an index heading. If Chap01.doc contains 
an entry for "architecture" on page 7, and Chap02.doc contains an entry for 
"architecture" on page 42, then the sequence { RD  Chap02.doc \f }{ RD  
Chap01.doc \f } would result in the index entry "architecture 42, 7". 

Then add the index field: 

� Insert> Reference> Index and Tables…>OK 

This will give a single index, generated from the embedded entries in the 
referenced documents. 

Selecting text 
Word has several ways of selecting text ranges and knowledge of them can 
speed the indexing process significantly. They are: 

� position the cursor at the beginning of the range 

� hold down Shift  
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� click at the end of the range  

Also: 

� double-click selects a word  

� triple-click selects the paragraph  

and:  

� position the cursor at the beginning of the range 

� hold down shift  

� press down-arrow, or ctrl-right arrow, or ctrl-end. 

Index after the Endnotes 
As an indexer you know that the usual position for an index is at the end of the 
book. If a book has Endnotes, however, it is not obvious how to achieve this in 
Word. 

To insert an Endnote, use: 

Insert> Reference> Footnote… 

 

Selecting Endnotes, gives us two choices – "End of section" and "End of 
document". Unfortunately, "End of document" means exactly that, and so 
nothing at all may come after it. Even though the index may be the last thing in 
the document file, the Endnotes will be positioned after the index. 

"End of section" would be OK as long as the entire text of the book is in a single 
section. If we have pages, some of which are landscape and some are portrait, 
then this is not practical either. 

The answer is to use "End of section" but then, in the first Section of the text, 
use: 
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� File> Page Setup> Layout tab 

� In the "Section" part at the top, check the "Suppress endnotes" tickbox. 

This means that the Endnotes for that section are postponed until the end of the 
next section. Keep doing this for each section of the text, throughout the whole 
document, until you reach the last section, and when you stop, that is where the 
Endnotes will be positioned. You can then insert another section to hold the 
Index and any other post-endnotes material. 

Suspect headings 
There are some index headings which you know might cause problems. For 
example (from a book on indexing): 

 See cross-refs, see also see-also cross-refs 

It would be wise to check the finished Word document and possibly correct the 
entries manually, if necessary, rather than work out the way of getting round the 
problem. 

 

Changing keystroke for Ctrl-Shift-\ 
I chose Ctrl-Shift-\ as the key combination because I thought it convenient to 
use and the combination is not used in standard Word. It may be, however, that 
you want to use a different keystroke combination. 

What the Ctrl-Shift-\ does is to run a Macro which I have called copyLocator. 
You can assign a different keystroke combination in Word 2003 as follows: 

• Right click on the toolbars  

• At the very bottom of the menu choose Customize...  

• Bottom right, Click on Keyboard...  

• In the Categories on the left, scroll down and select Macros  

• In the Macros list on the right, scroll down and select copyLocator  

• On the left it should show current assignments, click into the "Press 
new shortcut key:" box  

• Press a key combination that you want to assign  

• It will tell you what that key is currently assigned to  

• Select Normal.dot  

• Click on Assign  

Troubleshooting 
If no index is created and no errors are given, then no valid locators were found. 
Check the format of the index file and, in particular check that it actually 
contains what you think it does. 

The answer is: Se~ ~e cross-refs. see also see-also cross-refs 
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Memory Problems 

Word is very sensitive to memory allocation problems and can sometimes 
behave in bizarre ways. If anything strange happens and Word crashes or stops 
abnormally for any reason at all, it is essential to reboot the machine, rather than 
simply restarting Word. 

If the index file you are trying to embed is too large, cut it in half using a word 
processor – ensuring that you cut between main headings – don’t split the file in 
the middle of subheadings. Then embed the first file and then embed the second 
file. In this way, each embedding operation is less demanding on memory 
resources. 

Automation Error 

When a document has had a very large number of changes made to it, there can 
be some internal corruption which can result in Word crashing with 
"Automation Error" message. This is sometimes referred to as "Template Bloat". 
The actual error message produced is: 

Run-time error '-214741848 (80010108)': 
Automation error 
The object invoked has disconnected from its clients 
 
Word then locks up completely, the Winword.exe running at 97% cpu and  
it is even difficult to get task manager up. 

This is a problem with Word, not with WordEmbed, however, as WordEmbed is 
making hundreds or thousands of changes to the document, it may be the 
WordEmbed embedding process which triggers the error. 

The cure for this is, thankfully, very simple: 

� Reboot the machine 

� opening the problem document 

� turn Show/Hide on 

� Select the whole document except the final paragraph mark - position 
the cursor at the start of the document, hold down Shift and Ctrl, press 
the “End” key, then press the Back-Arrow key once 

� Ctrl-C (to copy it) 

� File> New> Blank  

� In the new file, Ctrl-V (to paste it) 

� Save the new file 

The new file will be identical in terms of content to the old file, but will 
probably be significantly smaller. The embedding process should now be 
problem free.  
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File Corruption 

Word files can become corrupt, particular large files which have been heavily 
worked on. It is therefore advisable, upon receiving a file, to Repair it.  

To do this, from within Word use File> Open.  

 

On the resulting window the Open button has a tiny drop-down menu beside it. 
Click on that and chose “Open and Repair”. 

Where has my toolbar gone? (Disabled templates) 

If Word crashes for any reason, for example a power failure while you are 
working, it will automatically disable any Add-in, such as WordEmbed, which 
was running at the time, “just to be on the safe side”. This means that you 
toolbar disappears completely and will not be reinstated, even by reinstallation. 
To re-enable the WordEmbed template, from within Word: 

Help> About MicroSoft Office Word 

This brings up the “About” window, but in the bottom corner is a button 
“Disabled Items…”. Click that button, select WordEmbedDistrib and click on 
“Enable”. 

Understanding exactly why this “Disabled Items” button is in quite such an 
obscure place is left as an exercise for the reader. 

Parentheses at the end of entries 

IF the heading contains parentheses AND the parentheses are at the end of the 
heading AND one of the locators is italic, this results in a separate heading 
including "\i" for the italic locators. 



WordEmbed 

https://jalamb.com/wordembed/  

26 

So, the heading: 

bone morphogenetic protein 2 (BMP2), 20–21, 55–57 

results in: 

bone morphogenetic protein 2 (BMP2), 20–21 
bone morphogenetic protein 2 (BMP2) \i, 55–57 

To resolve this, put the parentheses in braces (thus removing them from the 
sort): 

bone morphogenetic protein 2 {(} BMP2{)}, 36.70, 65.10 
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Using with SKY Index Professional 

SKY Settings 
To format the output from SKY as required by WordEmbed, 

In Sky: 

1. Choose Options>Index Options 

2. Chose the Locators tab 

3. Change the Volume separators input to be X 

4. Change the Chapter separators input to be X 

5. Click the Output Format tab 

6. Choose "RTF Spaces" from the Presets list 

7. Click OK (twice) 

If you wish to use Word as your Word processor from SKY, as in the tutorial 
which follows: 

8. Choose Options>Program Options 

9. Click the Word Processor tab 

10. Choose Word from the drop down list 

11. Click OK 

SKY Tutorial 
A tutorial for using WordEmbed with SKY is available for download from the 
website at https://jalamb.com/wordembed/  
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Using with CINDEX 

CINDEX Settings 
To produce the correct format file for use with WordEmbed from Cindex: 

� Edit> Preferences> Formatted Export tab 

� Select "Other" and type "=" in the box which follows 

� Create the index 

� Save the completed index as rtf using  
File> Save As… and select Rich Text Format (RTF)(*.rtf) from the 
dropdown list 

When embedding the file, on the WordEmbed Embed screen, enter a "=" into 
the Indent Marker box. 

CINDEX Hints 

Colons 

To include a colon in an index heading without causing a break to a subheading, 
for instance for Biblical references, it is necessary to surround the colon by { } 
in the RTF file. This can be done in Cindex: 

Genesis 1~{:~}25-26 

Quotes 

To include a single double-quote mark in a Word embedded index it is 
necessary to prefix it with a backslash: \" 

In order to get that past Cindex, it is necessary to prefix the backslash with 
another backslash: \\" 

For two double-quote marks, however, WordEmbed will treat the pair of 
backslash characters as indicating bold, so they need to be preceded by further 
backslashes: \\\\" 

In order to avoid have Word sort on the double-quote mark we need { } and 
arrive at: 

~{\\\\"~}Soult, Marshal~{\\\\"~} 

CINDEX Tutorial 
A tutorial for using WordEmbed with Cindex is available for download from the 
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website at https://jalamb.com/wordembed/  
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Using with MACREX 

MACREX Settings 
From the Options screen: 

� use Option 6 to turn off page range checking 

� use Option K to turn off Automerge to stop eliding of 'volume' numbers 

 

 

 


